Hello There, Guest! Login Register


could not find the Nurse Joy
#1
I use the "Catch and Release" script to hunt a Lavitar in "Sevault Canyon". Unfortunately, when I run the script it says

"[01:18:55] error: usePokecenter: could not find the Nurse Joy.
 [01:18:55] Bot stopped
 [01:18:55] Run Time: 14 seconds
 [01:18:55] Error during the script execution: Pathfinder / Lib / MoveTo / Pokecenter.lua: (38,4-60): usePokecenter() failed "

Is there anything I can do to solve this?

(Google translation - my English is horrible = /)
 
Reply
#2
Stand in the Pokecenter and run this script, then show us what it logs.

function onStart()
    data = getNpcData()
    for i = 1, #data do
        log("Npc name: " .. tostring(data[i]["name"]))
        log("    Npc X: " .. tostring(data[i]["x"]))
        log("    Npc Y: " .. tostring(data[i]["y"]))
        log("    Npc type: " .. tostring(data[i]["type"]))
        log("    Npc isBattler: " .. tostring(data[i]["isBattler"]))
        log("    Npc ID: " .. tostring(data[i]["id"]))
        log("    Npc los: " .. tostring(data[i]["los"]))    
    end
end
 
Reply
#3
He show it:

[13:00:09] Bot started
[13:00:09] Npc name:
[13:00:09] Npc X: 9
[13:00:09] Npc Y: 14
[13:00:09] Npc type: 26
[13:00:09] Npc isBattler: False
[13:00:09] Npc ID: 3086
[13:00:09] Npc los: 3
[13:00:09] Npc name:
[13:00:09] Npc X: 9
[13:00:09] Npc Y: 15
[13:00:09] Npc type: 10
[13:00:09] Npc isBattler: False
[13:00:09] Npc ID: 3087
[13:00:09] Npc los: 3
[13:00:19] No action executed: stopping the bot.
 
Reply
#4
Alright, the problem here is that the PRO developers didn't name the Nurse. ProShine requires an npc named "Nurse Joy" for usePokecenter() to work.

What you're going to need to do is change line 555:
return pf.useNearestPokecenter(getMapName())


To this:
if not pf.moveTo(getMapName(), "Pokecenter Seven Island") then
    return talkToNpcOnCell(9, 15)
end
 
Reply
#5
very well, thanks so much! Its now is work perfectly. Remember, work to my configs, because if change to off the option "healWhenStatused" and to true the option "useItems", not work.

thanks Wink
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)